Удаление папки /install/ - обязательно!

Файловый Архив

  • Неограниченное количество категорий и суб-категорий
  • Настройки прав доступа по группам
  • Настройки прав доступа по каждой категории
  • Предпросмотр медиа файлов: FLV, IFLV, F4A, F4V, MP4, MP3, MOV и других...
  • Мультизагрузка файлов - SWFUploader
  • Добавление файлов с сервера
Подробности и история обновлений продукта в этой теме
Loading

Go Back   форум vBSupport.org > > >
Register Изображения Меню vBsupport Files Manager Аллея Звёзд Реклама на форуме Search Today's Posts Mark Forums Read
  • Мемберка
  • Администраторам
  • Premoderation
  • For English speaking users
  • Изменения в правах
  • Каталог Фрилансеров
Пароли на скачивание файлов в Member Area меняются автоматически каждый день
Если вам нужно скачать какой то скрипт, за паролем ко мне в ЛС
привет какирам kerk
Ещё раз обращаем Ваше внимание: всё, что Вы скачиваете и устанавливаете на свой форум, Вы устанавливаете исключительно на свой страх и риск.
Сообщество vBSupport'а физически не в состоянии проверять все стили, хаки и нули, выкладываемые пользователями.
Помните: безопасность Вашего проекта - Ваша забота.
Убедительная просьба: при обнаружении уязвимостей или сомнительных кодов обязательно отписывайтесь в теме хака/стиля
Спасибо за понимание
На форуме введена премодерация ВСЕХ новых пользователей

Почта с временных сервисов, типа mailinator.com, gawab.com и/или прочих, которые предоставляют временный почтовый ящик без регистрации и/или почтовый ящик для рассылки спама, отслеживается и блокируется, а так же заносится в спам-блок форума, аккаунты удаляются
for English speaking users:
You may be surprised with restriction of access to the attachments of the forum. The reason is the recent change in vbsupport.org strategy:

- users with reputation < 10 belong to "simple_users" users' group
- if your reputation > 10 then administrator (kerk, Luvilla) can decide to move you into an "improved" group, but only manually

Main idea is to increase motivation of community members to share their ideas and willingness to support to each other. You may write an article for the subject where you are good enough, you may answer questions, you may share vbulletin.com/org content with vbsupport.org users, receiving "thanks" equal your reputation points. We should not only consume, we should produce something.

- you may:
* increase your reputation (doing something useful for another members of community) and being improved
* purchase temporary access to the improved category:
10 $ for 3 months. - this group can download attachments, reputation/posts do not matter.
20 $ for 3 months. - this group can download attachments, reputation/posts do not matter + adds eliminated + Inbox capacity increased + files manager increased permissions.

Please contact kerk or Luvilla regarding payments.

Important!:
- if your reputation will become less then 0, you will be moved into "simple_users" users' group automatically.*
*for temporary groups (pre-paid for 3 months) reputation/posts do not matter.
Не можете скачать вложение?
Изменения в правах групп пользователей
внимательно читаем эту и эту темы
Короткая версия - тут
Уважаемые пользователи!

На форуме открыт новый раздел "Каталог фрилансеров"

и отдельный раздел для платных заказов "Куплю/Закажу"

 
 
Old  
Статист
Простоузер
Post Новичкам! ISP Manager+Vbulletin 3.8. Проблемы в установке. 3

Я думаю многие сталкивались при установке Vbulletin 3.8 с такими ошибками как Strict Standards:

Скрин:

Все дело в том, что эти ошибки вылазят не случайно, в большинстве случаев это означает что скорее всего режим работы PHP на вашем хостинге работает некорректно.Это всё можно исправить двумя способами. Более опытные пользователи решают данную проблему правкой тех файлов из за которых возникла ошибка Strict Standards.Но есть и второй нюанс, если у вас стоит ISP Manager на хостинге, то нужно обратить внимание на одну деталь при создании домена(вашего сайта). Смотрим внимательно, когда вы создаете домен то в панели управления ISP Manager обратите внимание на дополнительные возможности:

Скрин:

Любой новичок может допустить эту ошибку.Как мы видим в Дополнительных Возможностях есть строка "режим работы php", тут и кроется вся разгадка. Просто нужно отключить исполнение CGI скриптов, а "режим работы php" выбрать модуль Apache. Если новичок пропустит этот нюанс, то по умолчанию получается, что "режим работы php" будет стоять CGI, соответственно мы и получаем ошибки Strict Standards, а новичок будет ломать голову из за чего возникла проблема. Если все делать верно, то у вас сразу пропадут эти Strict Standards и продукт установится без проблем. Будьте внимательней! И никаких ошибок при установке не возникнет.
 
Bot
Yandex Bot Yandex Bot is online now
 
Join Date: 05.05.2005
Реклама на форуме А что у нас тут интересного? =)
Old  
Smalesh
Эксперт
Default 4

Это НЕ РЕШЕНИЕ проблемы. Просто mod_php собран с 5.3, а CGI - 5.4. Ошибка не от режима работы php, ошибка от смены версии php.
 
Old  
Hobot
Эксперт
 
Hobot's Avatar
Default 1

картиночки в ширину надо было побольше.
 
Old  
Статист
Простоузер
Post 0

Quote:
Originally Posted by Smalesh View Post
Это НЕ РЕШЕНИЕ проблемы. Просто mod_php собран с 5.3, а CGI - 5.4. Ошибка не от режима работы php, ошибка от смены версии php.
Вы все правильно говорите, только речь не об этом. В данном примере приводится версия 5.3, и она не поменялась даже если включен CGI, хотя смотря у какого хостера, да вы правы на многих автоматом выставляется 5.4 и выше, при выборе CGI,в любом случае vbulletin не установится, так как это нелогично 5.3+CGI. Я просто привел пример где новичок может допустить ошибку при установке. Новичок выбрал допустим 5.3 версию и забыл выключить CGI скрипты, или изначально он их не выключил, и тут началось, новичок начинает изобретать велосипед и лезть в правку файлов, а зачем? Все может быть намного проще. И еще один момент, я здесь указал ISP Manager+Vbulletin 3.8. В данном менеджере если все делать верно, то и этих Strict Standards не будет.
 
Old  
YURSHAT
Coder
 
YURSHAT's Avatar
Default 3

Quote:
Originally Posted by Статист View Post
Strict Standards
Quote:
Originally Posted by Статист View Post
в большинстве случаев это означает что скорее всего режим работы PHP на вашем хостинге работает некорректно
На самом деле это означает только одно - ваша версия 3.8 не совместима с версией PHP на сервере и абсолютно неважно как там запущен PHP, как модуль Apache или через FastCGI. Панели (ISP, CPanel и т.д.) так же не имеют к этому никакого отношения.

И решений тут ровно три:
1. Правим PHP скрипты
2. Откатываем версию PHP
3. Обновляем движок до актуальной версии

Новичку нужно знать следующее: для vB 3.8.4 - 3.8.7 нужен PHP 5.2, а если новичок хочет юзать актуальные версии PHP, то следует ставить vB 3.8.9.
 
Old  
Smalesh
Эксперт
Default 2

А еще новичку надо знать, что версия 5.3 (не говоря уже о 5.2) снята с поддержки. Я уже год на все новые инсталляции ставлю от 5.4. Тоже сидели, правили файлы, устраняли ошибки - зато это стоило того.
 
Old  
Статист
Простоузер
Default 0

Quote:
Originally Posted by YURSHAT View Post
На самом деле это означает только одно - ваша версия 3.8 не совместима с версией PHP на сервере и абсолютно неважно как там запущен PHP, как модуль Apache или через FastCGI. Панели (ISP, CPanel и т.д.) так же не имеют к этому никакого отношения.
Не совсем согласен. Да, ваша версия не совместима с PHP? Почему она несовместима? Потому что новичок забыл снять галочку с CGI? Как это не важно какой PHP запущен? Если выставить модуль Apache и версию PHP 5.3 , то почему, то сразу становится всё совместимо и всё устанавливается,а если стоит PHP 5.3 и CGI то конечно же это несовместимо будет. На многих хостингах вообще тупо стоит Apache и без заморочек. Значит получается так, новичок увидел Strict Standards-это всё,несовместимость PHP, давайте править файлы? А глянуть слабо что в хостинге? Какие параметры,какая php стоит,как запущен PHP. Моя статья не призывает, что этим способом можно глобально решить проблему Strict, но во многих случаях косяк идет изначально от невнимательности новичка. Привел пример именно ISP , так как в других нет этих приколов,стоит Apache и всё.

Last edited by Статист : 11-08-2015 at 02:56 AM.
 
Old  
Luvilla
Блондинка с электро......
 
Luvilla's Avatar
Default 1

@Статист, с какой целью написана статья?
Если она претендует на то, чтобы быть полезной новичкам - то увы, статья нЕ принимается.
Если же это некие личные заметки о том, как лично Вам удалось побороть проблемы при установке конкретной версии движка на конкретном хостинге - да, хорошо, я придумаю, в какой раздел её перенести.
 
 

Tags
isp manager, strict standards, ошибка установки, установка vbulletin

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off




All times are GMT +4. The time now is 04:03 AM.


Powered by vBulletin® Version 3.0.3
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.