Владельцам 3.8.6: не поставили патч - потеряли форум!

Файловый Архив

  • Неограниченное количество категорий и суб-категорий
  • Настройки прав доступа по группам
  • Настройки прав доступа по каждой категории
  • Предпросмотр медиа файлов: FLV, IFLV, F4A, F4V, MP4, MP3, MOV и других...
  • Мультизагрузка файлов - SWFUploader
  • Добавление файлов с сервера
Подробности и история обновлений продукта в этой теме
Loading

Go Back   форум vBSupport.org > > >
Register Изображения Меню vBsupport Files Manager Аллея Звёзд Реклама на форуме Search Today's Posts Mark Forums Read
  • Мемберка
  • Администраторам
  • Premoderation
  • For English speaking users
  • Изменения в правах
  • Каталог Фрилансеров
Пароли на скачивание файлов в Member Area меняются автоматически каждый день
Если вам нужно скачать какой то скрипт, за паролем ко мне в ЛС
привет какирам kerk
Ещё раз обращаем Ваше внимание: всё, что Вы скачиваете и устанавливаете на свой форум, Вы устанавливаете исключительно на свой страх и риск.
Сообщество vBSupport'а физически не в состоянии проверять все стили, хаки и нули, выкладываемые пользователями.
Помните: безопасность Вашего проекта - Ваша забота.
Убедительная просьба: при обнаружении уязвимостей или сомнительных кодов обязательно отписывайтесь в теме хака/стиля
Спасибо за понимание
На форуме введена премодерация ВСЕХ новых пользователей

Почта с временных сервисов, типа mailinator.com, gawab.com и/или прочих, которые предоставляют временный почтовый ящик без регистрации и/или почтовый ящик для рассылки спама, отслеживается и блокируется, а так же заносится в спам-блок форума, аккаунты удаляются
for English speaking users:
You may be surprised with restriction of access to the attachments of the forum. The reason is the recent change in vbsupport.org strategy:

- users with reputation < 10 belong to "simple_users" users' group
- if your reputation > 10 then administrator (kerk, Luvilla) can decide to move you into an "improved" group, but only manually

Main idea is to increase motivation of community members to share their ideas and willingness to support to each other. You may write an article for the subject where you are good enough, you may answer questions, you may share vbulletin.com/org content with vbsupport.org users, receiving "thanks" equal your reputation points. We should not only consume, we should produce something.

- you may:
* increase your reputation (doing something useful for another members of community) and being improved
* purchase temporary access to the improved category:
10 $ for 3 months. - this group can download attachments, reputation/posts do not matter.
20 $ for 3 months. - this group can download attachments, reputation/posts do not matter + adds eliminated + Inbox capacity increased + files manager increased permissions.

Please contact kerk or Luvilla regarding payments.

Important!:
- if your reputation will become less then 0, you will be moved into "simple_users" users' group automatically.*
*for temporary groups (pre-paid for 3 months) reputation/posts do not matter.
Не можете скачать вложение?
Изменения в правах групп пользователей
внимательно читаем эту и эту темы
Короткая версия - тут
Уважаемые пользователи!

На форуме открыт новый раздел "Каталог фрилансеров"

и отдельный раздел для платных заказов "Куплю/Закажу"

 
 
Первый пост
Old  
smedvedev
Продвинутый
Default 0

Кто поможет в решение проблем с форумом 4.2.2 на РНР 5.5 , возникают ошибки с редактированием постов и т.д. правки которое выше написаны почтив се внес. но все находит еще баги

smedvedev добавил 20.03.2014 в 22:53
Редактирование текста, все та же ошибка, пересмотрел сто раз

вот это стоит:

PHP Code:
        // need to display smilies in code/php/html tags as literals
        
$text preg_replace_callback('#\[(code|php|html)\](.*)\[/\\1\]#siUe'"\$this->strip_smilies(str_replace('\\\"', '\"', '\\0'), true)"$text);
        return 
$text;
    } 
smedvedev добавил 20.03.2014 в 22:56
В теме включаю расширенный редактор для ответа и выходят такие ошибки:
[PHP]Warning: preg_replace_callback(): Requires argument 2, 'Array', to be a valid callback in ..../includes/class_wysiwygparser.php on line 310

Warning: preg_replace_callback(): Requires argument 2, '$this->strip_html_from_bbcode('\0')::[URL=$1$2', to be a valid callback in ..../includes/class_wysiwygparser.php on line 402

Warning: preg_replace_callback(): Requires argument 2, 'Array', to be a valid callback in ..../includes/class_wysiwygparser.php on line 462

Warning: preg_replace_callback(): Requires argument 2, 'Array', to be a valid callback in ..../includes/class_wysiwygparser.php on line 669[/PHP]

Новые, у кого еще так? я точно ничего лишнего не заменял.. все по вышеперечисленным правкам которое все писали сделал.

Важно: все ошибки данные возникают когда я хочу править под Админом, под простыми юзерами нормально все

_http://letvincha.com/forum/showthread.php?t=5 вот сайт, если вы хотите потестить

Last edited by smedvedev : 03-21-2014 at 01:02 AM. Reason: Добавлено сообщение
 
Bot
Yandex Bot Yandex Bot is online now
 
Join Date: 05.05.2005
Реклама на форуме А что у нас тут интересного? =)
Old  
UniversalUserIS
Специалист
 
UniversalUserIS's Avatar
Default 1

Памятка обновлена, добавлен фикс ошибки Warning: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in ....\includes\class_bbcode.php on line 2958, убраны некоторые неверные решения в частности 522 строка файла ..../includes/class_bbcode_alt.php должна выглядеть так:
PHP Code:
$text preg_replace_callback('#\[(code|php|html)\](.*)\[/\\1\]#iU', array($this'strip_smilies_callback'), $text); 
 
Old  
UniversalUserIS
Специалист
 
UniversalUserIS's Avatar
Default 2

Собрал в архиве все 19 файлов, что подвергались правке на моем форуме для совместимости vB 4.2.2 с PHP 5.5.x. Замена пофиксит не все ошибки, но большинство из них, те которые заметил и до которых добрался. Отмечу, что ошибки именно фиксились, а не скрывались с глаз костылями типа define('SKIP_ALL_ERRORS', true);

Last edited by UniversalUserIS : 03-27-2014 at 12:31 AM.
 
Old  
UniversalUserIS
Специалист
 
UniversalUserIS's Avatar
Default 0

Буквально сегодня словил:
Warning: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in ....\includes\class_bbcode_alt.php on line 333
Ищем:
PHP Code:
if ($has_img_code == OR $has_img_code == 3)
        {
            if (
$do_imgcode AND ($this->registry->userinfo['userid'] == OR $this->registry->userinfo['showimages']))
            {
                
// do [img]xxx[/img]
                
$bbcode preg_replace('#\[img\]\s*(https?://([^*\r\n]+|[a-z0-9/\\._\- !]+))\[/img\]#iUe'"\$this->handle_bbcode_img_match('\\1')"$bbcode);
            }
        }

        return 
$bbcode;
    } 
Заменяем:
PHP Code:
if ($has_img_code == OR $has_img_code == 3)
        {
            if (
$do_imgcode AND ($this->registry->userinfo['userid'] == OR $this->registry->userinfo['showimages']))
            {
                
// do [img]xxx[/img]
                
$bbcode preg_replace_callback('#\[img\]\s*(https?://([^*\r\n]+|[a-z0-9/\\._\- !]+))\[/img\]#iU', array($this'handle_bbcode_img_match_callback'), $bbcode);
            }
        }

        return 
$bbcode;
    }
protected function 
handle_bbcode_img_match_callback($matches)
        {
            return 
$this->handle_bbcode_img_match($matches[1]);
        } 
 
Old  
Sven
Верстальщик
 
Sven's Avatar
Default 0

Меня удивило, что 4.2.2 которая вроде как подогнана под пхп 5.4 - всё равно ловит ошибки на пхп 5.4 =/
 
Old  
UniversalUserIS
Специалист
 
UniversalUserIS's Avatar
Default 0

@Sven, это деприкейты PHP 5.5.x, просто я подумал, что мало ли может кто еще привязан к PHP 5.5 как я, вот и устраняю эти деприкейты потихоньку, а решениями делюсь здесь.
 
Old  
Sven
Верстальщик
 
Sven's Avatar
Default 0

Я вчера столкнулся с ошибками
Quote:
Originally Posted by UniversalUserIS View Post
Warning: Declaration of vBForum_Item_SocialGroupDiscussion::getLoadQuery() should be compatible with vB_Model::getLoadQuery($required_query = '', $force_rebuild = false) in ....\packages\vbforum\item\socialgroupdiscussion.php on line 337
Quote:
Originally Posted by UniversalUserIS View Post
Warning: Declaration of vBForum_Item_SocialGroupMessage::getLoadQuery() should be compatible with vB_Model::getLoadQuery($required_query = '', $force_rebuild = false) in ....\packages\vbforum\item\socialgroupmessage.php on line 261
На пхп 5.4..
 
Old  
UniversalUserIS
Специалист
 
UniversalUserIS's Avatar
Default 0

@Sven, вот как, да уж действительно, удивлению нет предела
 
Old  
taravasya
Знаток
 
taravasya's Avatar
Default 0

Ошибка несколько иного плана..
При объединении сообщений, если требуется ввести пароль админа/модера, после ввода пароля и переадресации, булка матюгается:
"Ваше сообщение слишком короткое" и в редакторе в самом деле пусто. Если вернуться назад, и повторить процедуру, то уже без ввода пароля, всё проходит без ошибки. До обновления, такого не наблюдалось... Решения пока не нашёл, может быть кто-то подскажет?
 
Old  
UniversalUserIS
Специалист
 
UniversalUserIS's Avatar
Default 1

@taravasya, это все связано с заменой функции unserialize() на json_encode() значение value которой не работает с кодированными в cp1251 данными. Так что варианта здесь два: либо откатывать последний PL (что и не вариант вовсе, ибо безопасность превышего всего), либо менять кодировку форума в UTF-8. Третьего не дано.

Last edited by UniversalUserIS : 05-08-2014 at 08:14 PM.
 
 

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off




All times are GMT +4. The time now is 04:31 AM.


Powered by vBulletin® Version 3.5.1
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.