У Вас в настройках PHP register_globals=ON? какеры идут к Вам!!!

Файловый Архив

  • Неограниченное количество категорий и суб-категорий
  • Настройки прав доступа по группам
  • Настройки прав доступа по каждой категории
  • Предпросмотр медиа файлов: FLV, IFLV, F4A, F4V, MP4, MP3, MOV и других...
  • Мультизагрузка файлов - SWFUploader
  • Добавление файлов с сервера
Подробности и история обновлений продукта в этой теме
Loading

Go Back   форум vBSupport.org > > >
Register Изображения Меню vBsupport Files Manager Аллея Звёзд Реклама на форуме Search Today's Posts Mark Forums Read
  • Мемберка
  • Администраторам
  • Premoderation
  • For English speaking users
  • Изменения в правах
  • Каталог Фрилансеров
Пароли на скачивание файлов в Member Area меняются автоматически каждый день
Если вам нужно скачать какой то скрипт, за паролем ко мне в ЛС
привет какирам kerk
Ещё раз обращаем Ваше внимание: всё, что Вы скачиваете и устанавливаете на свой форум, Вы устанавливаете исключительно на свой страх и риск.
Сообщество vBSupport'а физически не в состоянии проверять все стили, хаки и нули, выкладываемые пользователями.
Помните: безопасность Вашего проекта - Ваша забота.
Убедительная просьба: при обнаружении уязвимостей или сомнительных кодов обязательно отписывайтесь в теме хака/стиля
Спасибо за понимание
На форуме введена премодерация ВСЕХ новых пользователей

Почта с временных сервисов, типа mailinator.com, gawab.com и/или прочих, которые предоставляют временный почтовый ящик без регистрации и/или почтовый ящик для рассылки спама, отслеживается и блокируется, а так же заносится в спам-блок форума, аккаунты удаляются
for English speaking users:
You may be surprised with restriction of access to the attachments of the forum. The reason is the recent change in vbsupport.org strategy:

- users with reputation < 10 belong to "simple_users" users' group
- if your reputation > 10 then administrator (kerk, Luvilla) can decide to move you into an "improved" group, but only manually

Main idea is to increase motivation of community members to share their ideas and willingness to support to each other. You may write an article for the subject where you are good enough, you may answer questions, you may share vbulletin.com/org content with vbsupport.org users, receiving "thanks" equal your reputation points. We should not only consume, we should produce something.

- you may:
* increase your reputation (doing something useful for another members of community) and being improved
* purchase temporary access to the improved category:
10 $ for 3 months. - this group can download attachments, reputation/posts do not matter.
20 $ for 3 months. - this group can download attachments, reputation/posts do not matter + adds eliminated + Inbox capacity increased + files manager increased permissions.

Please contact kerk or Luvilla regarding payments.

Important!:
- if your reputation will become less then 0, you will be moved into "simple_users" users' group automatically.*
*for temporary groups (pre-paid for 3 months) reputation/posts do not matter.
Не можете скачать вложение?
Изменения в правах групп пользователей
внимательно читаем эту и эту темы
Короткая версия - тут
Уважаемые пользователи!

На форуме открыт новый раздел "Каталог фрилансеров"

и отдельный раздел для платных заказов "Куплю/Закажу"

 
 
Old  
fagediba
Простоузер
Default Мб кто-нибудь распишет подробно как добавить тег подсветки языка программирования? 0

Здравствуйте. Собственно нужен тег подстветки языка



Т.е. нужен тег
[html]

HTML Code:
<a href="ssilka">ankor</a>
Только для языка что выше.

Вобла четверка

Last edited by fagediba : 06-17-2011 at 03:10 PM.
 
Bot
Yandex Bot Yandex Bot is online now
 
Join Date: 05.05.2005
Реклама на форуме А что у нас тут интересного? =)
Old  
mindframe
Специалист
 
mindframe's Avatar
Default 1

1C?
http://www.vbulletin.org/forum/showthread.php?t=93071
Ставим этот продукт и затем добавляем в геши файл из аттача ну и добавляем в сам класс геши 1с.
Attached Files
File Type: php c1.php (13.7 KB, 5 views)
 
Old  
fagediba
Простоузер
Default 0

Там я так понимаю для 3.5, может кто нибудь сюда залить файл отсюда

Может кто-нибудь скопировать сюда код для четверки и прикрепленные к постам файлы с этой страницы
http://www.vbulletin.org/forum/showt...41#post2007541

Нужно содержимое постов с прикрепленными файлами
108
115
116

Также нужно содержимое вот этого поста
http://www.vbulletin.org/forum/showp...3&postcount=37
http://www.vbulletin.org/forum/showp...9&postcount=39
http://www.vbulletin.org/forum/showp...2&postcount=41

Last edited by fagediba : 11-04-2010 at 04:33 AM.
 
Old  
mindframe
Специалист
 
mindframe's Avatar
Default 1

#108
Quote:
Originally Posted by artvs View Post
What to do:
1) download and import product from attachment.
2) find file /admincp/misc.php and make a backup copy of it
3)in this file find
Code:
WHERE title IN ('bbcode_quote', 'bbcode_php', 'bbcode_code', 'bbcode_html', 'bbcode_video')
replace it with
Code:
WHERE title IN ('bbcode_quote', 'bbcode_php', 'bbcode_code', 'bbcode_html', 'bbcode_video', 'bbcode_highlight')
4) find
Code:
           'bbcode_video' =>& $bbcodelist["$tlist[bbcode_video]"],
add afrer
Code:
            'bbcode_highlight' =>& $bbcodelist["$tlist[bbcode_highlight]"],
5) find
Code:
            'bbcode_video' => intval($tlist['bbcode_video_styleid']),
add after
Code:
            'bbcode_highlight' => intval($tlist['bbcode_highlight']),
5) upload this file to ftp
6) go to admin panel and rebuild post cache

Hack usage:
[ syntax = cpp ] or [ highlight = cpp ] or [ code = cpp ] (without spaces)


I also would reccomend to obtain latest version of geshi.
Продукт: http://rghost.ru/3139956

#115

Quote:
Originally Posted by JarkkoL View Post
Does anyone have a patch for vb4.0.2 to fix the above problem?

Edit: Ok, I was able to fix it by adding the following two lines to the product-advhighlight.xml file in artvs attachment:
Code:
    if(!is_array($specialtemplates))
    	$specialtemplates = array();
above this line:
Code:
$specialtemplates = array_merge($specialtemplates, array('bbcode_highlight','bbcode_highlight_printable'));
#116

Quote:
Originally Posted by JarkkoL View Post
I made few changes to the product-advhighlight.xml file posted by artvs to make this mod work properly with vb4.0.2. I used latest GeSHi (1.0.8.6) with this mod:

- Added the is_array() check mentioned above.

- Changed the bbcode_highlight template to use "Maximum [CODE] Lines" defined in BB Code Settings. Previous version printed all the lines to the page regardless how long code you pasted within the code-tags, while this version limits the code window height and adds vertical scrollbar for code with more lines. It's doesn't limit the height exactly to the "Maximum [CODE] Lines" (I guess because of the different fonts used in the standard vB code tag and GeSHi), but is pretty close anyway (:

- Changed GeSHi to use GESHI_HEADER_PRE_VALID instead of GESHI_HEADER_DIV. This fixes word wrapping issue in the code window, i.e. previous version wrapped long code lines while this version adds horizontal scrollbar in that case.

- Fixed typos ;)


Disclaimer: I'm newbie when it comes to php & vb modding, so use this version at your own discretion (:
Продукт: http://rghost.net/3139959
 
Old  
fagediba
Простоузер
Default 0

Поставил. В файле c1.php там ошибки есть, не хватает скобки и запятой. Это я исправил.

Я так понимаю в файле geshi.php нужно что-то дописать про этот c1.php?

Плагин работает, но не совсем так, как надо. Допустим

[code=java]dsdfdsfdsf цикл Цикл
var wewerew
1221231 [/code]

Форматирует текст так:

Код java:
dsdfdsfdsf цикл Цикл
var wewerew
1221231

Но если потом редактировать пост, или делать предварительный просмотр - то обратно в бб код не форматируется.
Вобла 4.0.5




fagediba добавил 04.11.2010 в 13:40
Код 1c:
Процедура ОбработкаПроведения(Отказ, Режим)
Для Каждого ТекСтрокаТовары Из Товары Цикл
// регистр ЦеныПоставщиков
Движение = Движения.ЦеныПоставщиков.Добавить();
Движение.Период = Дата;
Движение.Регистратор = Ссылка;
Движение.Поставщик = Контрагент;
Движение.Номенклатура = ТекСтрокаТовары.Номенклатура;
Движение.Цена = ТекСтрокаТовары.Цена;

// регистр ОстаткиНоменклатуры Приход
Движение = Движения.ОстаткиНоменклатуры.Добавить();
Движение.ВидДвижения = ВидДвиженияНакопления.Приход;
Движение.Период = Дата;
Движение.Регистратор = Ссылка;
Движение.Номенклатура = ТекСтрокаТовары.Номенклатура;
Движение.Количество = ТекСтрокаТовары.Количество;
Движение.Сумма = ТекСтрокаТовары.Сумма;
Движение.Склад = Склад;

// регистр Управленческий
Движение = Движения.Управленческий.Добавить();
Движение.СчетДт = ПланыСчетов.Управленческий.Товары;
Движение.СчетКт = ПланыСчетов.Управленческий.Поставщики;
Движение.Период = Дата;
Движение.Регистратор = Ссылка;
Движение.Сумма = ТекСтрокаТовары.Сумма;
Движение.КоличествоДт = ТекСтрокаТовары.Количество;
Движение.Содержание = "Покупка товара";
Движение.СубконтоДт[ПланыВидовХарактеристик.ВидыСубконто.Номенклатура] = ТекСтрокаТовары.Номенклатура;
Движение.СубконтоКт[ПланыВидовХарактеристик.ВидыСубконто.Контрагенты] = Контрагент;
КонецЦикла;
// записываем движения регистров
//}}__КОНСТРУКТОР_ДВИЖЕНИЙ_РЕГИСТРОВ
КонецПроцедуры



fagediba добавил 04.11.2010 в 13:42
Вот такой кошмар.

Даже если это можно подправить - главное то, что стоит отредактировать такое сообщение и все напрочь слетает, обратно в бб код не преобразуется. Т.е. тег сохраняет в базу уже отформатированный текст, а не бб код.

fagediba добавил 04.11.2010 в 13:56
Неправильно обрабатывает из-за русских букв. Т.е. видимо в парсер нужно в регулярные выражения добавить обработку русских букв.

Но вот проблема с обратным преобразованием в бб код даже не знаю в чем дело, если так и задумано - весь модуль шлак откровенный, если в чем-то ошибка - то в чем может быть?

fagediba добавил 04.11.2010 в 14:26
Код подправил, получилось почти то, что нужно:

Процедура ОбработкаПроведения(Отказ, Режим)
Для Каждого ТекСтрокаТовары Из Товары Цикл
// регистр ЦеныПоставщиков
Движение = Движения.ЦеныПоставщиков.Добавить();
Движение.Период = Дата;
Движение.Регистратор = Ссылка;
Движение.Поставщик = Контрагент;
Движение.Номенклатура = ТекСтрокаТовары.Номенклатура;
Движение.Цена = ТекСтрокаТовары.Цена;

// регистр ОстаткиНоменклатуры Приход
Движение = Движения.ОстаткиНоменклатуры.Добавить();
Движение.ВидДвижения = ВидДвиженияНакопления.Приход;
Движение.Период = Дата;
Движение.Регистратор = Ссылка;
Движение.Номенклатура = ТекСтрокаТовары.Номенклатура;
Движение.Количество = ТекСтрокаТовары.Количество;
Движение.Сумма = ТекСтрокаТовары.Сумма;
Движение.Склад = Склад;
Справочники Количество Дата
а И
:
;
дата
// регистр Управленческий
Движение = Движения.Управленческий.Добавить();
Движение.СчетДт = ПланыСчетов.Управленческий.Товары;
Движение.СчетКт = ПланыСчетов.Управленческий.Поставщики;
Движение.Период = Дата;
Движение.Регистратор = Ссылка;
Движение.Сумма = ТекСтрокаТовары.Сумма;
Движение.КоличествоДт = ТекСтрокаТовары.Количество;
Движение.Содержание = "Покупка товара";
Движение.СубконтоДт[ПланыВидовХарактеристик.ВидыСубконто.Номенклатура] = ТекСтрокаТовары.Номенклатура;
Движение.СубконтоКт[ПланыВидовХарактеристик.ВидыСубконто.Контрагенты] = Контрагент;
КонецЦикла;
// записываем движения регистров
//}}__КОНСТРУКТОР_ДВИЖЕНИЙ_РЕГИСТРОВ
КонецПроцедуры



Осталось только сделать, чтобы текст по умолчанию был не черным, а синим.

Ну и самое главное: при редактировании сообщения все слетает, обратно в бб код не преобразуется.




fagediba добавил 04.11.2010 в 14:35
Я нащупал в чем проблема кажись: в Wyswyg - если он отрублен, то вроде работает. А если врублен - он переводит бб код в форматирование автоматом.

Т.е. тут дело в том, что он не должен. Например код [ code ] он не трогает, а код [ code = java ] трогает. Нужно сделать чтобы он не трогал этот бб код

fagediba добавил 04.11.2010 в 14:49
Может кто-нибудь подсказать 2 вещи:

1. Куда копать чтобы отключить в WYSWYG обработку добавленного тега, чтобы он пропускал его.

2. Текст по умолчанию должен быть синим, а не черным внутри тега

fagediba добавил 04.11.2010 в 16:02
Если использовать так

[ highlight=1c]Код java:
dsfsdf
12313 false

[/ highlight]

==========
апдейт:
Кажись нашел как отключить чтобы WYSWYG не обрабатывал код CODE

открыл файл
class_bbcode_alt.php

Нашел

var $unparsed_tags = array(
'thread',
'post',
'quote',
'highlight',
'noparse',
'video',

добавил ниже
'code',

и собственно перестало преобразовывать этот тег, стало нормально работать.
===========
То все окей, wyswyg не обрабатывает тег

1. Теперь осталось только текст по умолчанию сменить на синий с черного

2. Сделать отдельным тегом это, написано это тут
http://www.vbulletin.org/forum/showp...3&postcount=37
http://www.vbulletin.org/forum/showp...9&postcount=39
http://www.vbulletin.org/forum/showp...2&postcount=41

Скопируйте кто-нибудь

Last edited by fagediba : 11-04-2010 at 05:46 PM. Reason: Добавлено сообщение
 
Old  
Kazak
Продвинутый
Default 1

Quote:
Originally Posted by Andreas View Post
If you just want [as] for ActionScript, then change it to
PHP Code:
$this->tag_list['no_option']['as'
as well as
PHP Code:
function handle_bbcode_highlight(&$parser$code
and

PHP Code:
$geshi = new GeSHi($code'ActionScript'$path); 
Quote:
Originally Posted by garrynewman View Post
Ok, finally.. for anyone wanting tags like [sql]code[/sql] and [lua]code[/lua].. here's an example for Lua..

Code:
if (!function_exists('handle_bbcode_lua'))
{
    function handle_bbcode_lua(&$parser, $code, $type)
    {
        return handle_bbcode_highlight( $parser, $code, 'lua' );
    }
}

$this->tag_list['no_option']['lua'] = array(
    'callback' => 'handle_external',
    'strip_empty' => true,
    'stop_parse' => true,
    'disable_smilies' => true,
    'disable_wordwrap' => true,
    'strip_space_after' => 1,
    'external_callback' => 'handle_bbcode_lua'
);
Just add it near the bottom of the bbcode_create hook.


Quote:
Originally Posted by Andreas View Post
[sql]truncate post_parsed[/sql]
 
Old  
fagediba
Простоузер
Default 0

Чтобы сделать тег [1c]

В файле
class_bbcode.php

В самом низу перед
($hook = vBulletinHook::fetch_hook('bbcode_fetch_tags')) ? eval($hook) : false;
И после
if (($vbulletin->options['allowedbbcodes'] & ALLOW_BBCODE_HTML) OR $force_all)
{
// [HTML]
$tag_list['no_option']['html'] = array(
'callback' => 'handle_bbcode_html',
'strip_empty' => true,
'stop_parse' => true,
'disable_smilies' => true,
'disable_wordwrap' => true,
'strip_space_after' => 2
);
}

Добавил следующий код:


///////////////////////////////////
if (!function_exists('handle_bbcode_1c'))
{
function handle_bbcode_1c(&$parser, $code, $type)
{
return handle_bbcode_highlight( $parser, $code, '1c' );
}
}

$tag_list['no_option']['1c'] = array(
'callback' => 'handle_external',
'strip_empty' => true,
'stop_parse' => true,
'disable_smilies' => true,
'disable_wordwrap' => true,
'strip_space_after' => 1,
'external_callback' => 'handle_bbcode_1c'
);
////////////////////////////////////////

Заработало.

Остались следующие проблемы:
1. Теперь осталось сделать так, чтобы цвет по стандарту был синий, а не черный.
2. Большие куски кода переводит все в нижний регистр, заглавные буквы заменяет маленькими (заметил что это происходит если есть слова написанные капслоком (т.е. верхним регистром)

fagediba добавил 04.11.2010 в 22:33
Делает маленькими когда

ВВВВВВВВYYYYYYYYYYYY

Есть вот такое слово из заглавных букв разных раскладок. Тоже самое и с тегом CODE - это баг воблы значит. Нужно искать где-то ошибку в самой вобле

Может быть кто-то за деньги готов разобраться с этими проблемами, там уже немного осталось?

fagediba добавил 04.11.2010 в 22:44
Все, проблему с преобразование в нижний регистр решил - нужно в админке выключить предотвращение КРИКА - эта штука неправильно совершенно обрабатывает все

Осталась последняя проблема: нужно чтобы тег помещался в теги

<font color="blue"> </font>

Может кто-нибудь подскажет как это сделать

fagediba добавил 04.11.2010 в 23:29
Все, решил проблему:

Нужно удалить продукт, в xml файле найти

////////////////////
$blockheight = $parser->fetch_block_height($code);
$templater = vB_Template::create($parser->printable ? 'bbcode_highlight_printable' : 'bbcode_highlight');
$templater->register('type', $type);
$templater->register('code', $code);
$templater->register('blockheight', $blockheight);
$errors = error_get_last();
$html = $templater->render();

return $html;

}
}
///////////////////////////////////////

заменить на
//////////////////////////////////////
$blockheight = $parser->fetch_block_height($code);
$templater = vB_Template::create($parser->printable ? 'bbcode_highlight_printable' : 'bbcode_highlight');
$templater->register('type', $type);
$templater->register('code', $code);
$templater->register('blockheight', $blockheight);
$errors = error_get_last();
$html = $templater->render();

if ( ( $type == '1c' ) || ( $type == '1с' ) )
return '<font color="Blue">' . $html . '</font>';
else
return $html;

}
}
//////////////////////////////////

и импортировать заново

Last edited by fagediba : 11-05-2010 at 12:29 AM. Reason: Добавлено сообщение
 
Old  
Zerony
Простоузер
Default 0

mindframe перезалей свои файлики плз!

Zerony добавил 14.04.2011 в 21:12
А что значит go to admin panel and rebuild post cache, и как это сделать?

Last edited by Zerony : 04-14-2011 at 10:12 PM. Reason: Добавлено сообщение
 
Old  
Recew
Гость
Default

Перезалейте
 
Old  
fagediba
Простоузер
Default 0

Quote:
Originally Posted by Recew View Post
Перезалейте
Продукт работает и на 4.1.4
Attached Files
File Type: rar original_product-advhighlight_116.rar (1.7 KB, 5 views)
 
 

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off




All times are GMT +4. The time now is 01:59 AM.


Powered by vBulletin® Version 3.0.6
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.